We are currently investigating an unexpected outage

Incident Report for fieldd

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 15:00 PDT

Investigating

We are currently investigating an unexpected outage. Our team is working hard to identify the issue & rectify it as soon as possible.
Posted Apr 18, 2025 - 14:39 PDT
This incident affected: fieldd Online CRM and fieldd Online Bookings.