Square Outage
Incident Report for fieldd
Resolved
Square seems to be back operational. Please contact Square if issues persist with POS payments.
Posted Feb 10, 2022 - 10:42 PST
Identified
Waiting for Square for more information on the matter
Posted Feb 10, 2022 - 10:32 PST
Monitoring
We are monitoring Square for updates
Posted Feb 10, 2022 - 10:32 PST
Investigating
Square is currently down, users using Square for payments may temporarily experience issues.
Please contact Square for more information.
Posted Feb 10, 2022 - 10:29 PST