Brief Maintenance Update
Incident Report for fieldd
Resolved
This incident has been resolved.
Posted Jun 29, 2021 - 16:29 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 29, 2021 - 16:25 PDT
Investigating
We are launching a performance update & will be back live in the next few minutes
Posted Jun 29, 2021 - 16:24 PDT
This incident affected: Service App, fieldd Online CRM, and fieldd API.